Make compatible with PHP 8 #67

Merged
discomrade merged 1 commits from php8-compat into config 1 year ago
Collaborator

This branch is from my old leftypol_lainchan port of vichan's php8-compat branch.


IMPORTANT: This upgrade moves the included library packages to Composer (PHP package manager), so composer needs to be installed on the server and composer update then composer install must be run before rebuilding.

This has been tested with PHP 7.2, PHP 7.4 and PHP 8.0. It is NOT yet compatible with PHP 8.1.

This branch is from my old leftypol_lainchan port of [vichan's php8-compat branch](https://github.com/vichan-devel/vichan/tree/php8-compat). ----- **IMPORTANT:** This upgrade moves the included library packages to Composer (PHP package manager), so composer needs to be installed on the server and `composer update` then `composer install` must be run before rebuilding. This has been tested with PHP 7.2, PHP 7.4 and PHP 8.0. It is NOT yet compatible with PHP 8.1.
discomrade added 1 commit 1 year ago
discomrade merged commit 5190d63f48 into config 1 year ago
discomrade deleted branch php8-compat 1 year ago
The pull request has been merged as 5190d63f48.
Sign in to join this conversation.
No reviewers
No Milestone
No project
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This pull request currently doesn't have any dependencies.

Loading…
There is no content yet.